Cannot logon because the application version is older than the company database

Discussion in 'Microsoft Accounting' started by bradleary@gmail.com, May 24, 2007.

  1. Guest

    If I try to logon to SBA through the API, I get the message "Cannot
    logon because the application version is older than the company
    database." It had been working fine for about a month before it
    suddenly stopped working.

    I have seen several other posts to this group with the same error
    message. However, they got the message by opening the sba applicaiton
    and then opening their company. If I do that, my company opens just
    fine. I only get the message when I connect through the API.

    The recommended solution to the others was to install SP3. But I
    already have SP3 and if I try to install it again, it tells me it has
    already been applied.

    I found a download for SP4, but it said "It is only recommended to
    install this update if you wish to have compatibility with Windows
    Vista or Office Accounting 2007." I don't have Vista or Accounting
    2007. I tried installing it anyways, but it required Outlook, which I
    don't have either.

    Any ideas would be appreciated.
     
    , May 24, 2007
    #1
    1. Advertisements

  2. Guest

    I have almost the same problem on another computer, but instead it's
    the database version that is too old. Again, I can open the company
    just fine by opening SBA, but I get teh error when trying to connect
    through the API.

    Here is the error message: "Cannot logon because the company database
    version is older than the application version."

    This seems like it should be an easier fix. There must be some way
    for SBA to update its database. I'd expect it to do that every time a
    service pack is applied.

    Any ideas?
     
    , May 30, 2007
    #2
    1. Advertisements

  3. Jesper [MS] Guest

    Hi

    If you can open the database with the SBA application but not when using the
    SDK it means either that the SDK is not connecting to the same database
    (i.e. you have more than one database and the one you connect to in the SDK
    is older while the one you connect to through SBA is the correct version) or
    that the SDK is a different version.

    I'm guessing it's probably the first option you are seeing - try verifying
    the content of the sbc-file you use to open the database with - if you open
    it in Notepad you can see the name of the database and server you are
    opening. Compare that name to the list of databases you can see from the
    Data Tools' Delete dialog.
    Also compare the versions of the databases listed in that dialog with the
    file versions of the sbaapi.dll you are using.

    I also recommend you go through the new Loader to connect to a database and
    get the SDK - it is available in MOA 2007.
     
    Jesper [MS], May 30, 2007
    #3
  4. Guest

    Thanks a lot!

    That's exactly what I needed to know. In my first scenario, the
    company database version was 1.0.4224.0 and the sbaapi.dll version was
    1.0.3713.0. The second scenario was the same problem with the
    database and dll versions swapped.

    I've been pounding my head against this off and on for a while, so I
    really appreciate your help.
     
    , May 30, 2007
    #4
  5. paul bakhoum Guest

    Hi so im having this same problem with accounting 2007 pro. the database has an different version installed. how do I change the database on the remote computer to match the database?
     
    paul bakhoum, Aug 19, 2010
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.