MOA Pro 07 upgrade starts giving "Company on Remote Machine...Must Upgrade" errors

Discussion in 'Microsoft Accounting' started by thyde, Apr 26, 2007.

  1. thyde

    thyde Guest

    Hi - I've been using SBA 06 since it was in beta (actualy back to the
    days of SBM! wow!), quite successfully in a per-to-peer multi-user
    setup, and after about 6 months of test of MOA Pro 07, upgraded my
    production system from SBA 06 to MOA 07. The sql server is a
    standalone XP Pro SP2 machine, and I let MOA upgrade the server
    instance and the company data by itself, without errors.
    The permissions were checked, the sbc shortcuts updated, and all
    remote users were confirmed operational, having upgraded also from
    SBA06 using the VERY SAME INSTALL EXECUTABLE on all machines. (The
    upgrade was done using the single-download executable from the MS
    site, with trial keys until my physical media and full keys arrived).

    Once again, the upgrade was confirmed and working, with live data and
    multiple users happy with the system fully upgraded.

    After 2 days of successful operation, my backup script ran (it doesn't
    run on weekends)...it tried to backup the wrong database (I forgot to
    update the instance name in the script), and for some reason, the
    server stalled. I had backup personnel restart the machine.

    Now, each time a remote user attempts to connect, they get the "This
    company is on a remote machine, it needs to be upgraded." message. I
    can RDP (remote desktop) into the server, or even console locally and
    run MOA 07 just fine, on the same database. The company file is in
    multi-user mode, and the shortcut was distributed to each user, and
    once again, before the server restart, the upgrade was confirmed
    operational.

    I have restarted my test platform multiple times, migrated the new
    live database over, restarted, tried to duplicate the error, and no
    luck. I'm considering cleaning MOA/SBA off the server, installing
    SqlExpress05 by itself and restoring the tables from the existing MOA
    db.

    All users have the appropriate permissions, and can "touch" the other
    server shares without issue.

    Any thoughts out there? Anyone have a successful standalone
    SqlExpress05 installation?

    Thanks,

    TEd.
     
    thyde, Apr 26, 2007
    #1
    1. Advertisements

  2. thyde

    Jesper [MS] Guest

    Hi Ted

    You have probably hit some interesting combination of upgrade/remote
    scenarios and to get out of it I should probably give a quick overview of
    the sbc-file behavior.

    So basically:

    1. The sbc-file that you use to open a company with is just a txt-file
    containing the name of the computer and database to open. Try opening it in
    Notepad and see what I mean.
    2. The message you are getting indicates without doubt that you are
    connecting to a database (whether locally or remotely) and that database has
    a version which is less than the application you are connecting with.
    3. When a company is upgraded from SBA 2006 to MOA 2007 we actually copy the
    whole database to the new SQL Express instance and "stamp" the old database
    as unusable. In this process we also repoint the sbc-file you used to open
    that company with, to point to the new database so the user should notice a
    difference. This means that you could have a number of databases and/or
    sbc-files which might account for the scenario you see here (but it might
    not be the problem).
    4. When you restore a backup you can either select an existing sbc-file or
    enter a new sbc-file and if you enter a new sbc-file it will create a new
    database for your company.

    So the first thing to do could be to open the sbc-file in Notepad and verify
    that the sbc-files which doesn't work for you are pointing to the same
    database as the sbc-file which does work.

    My initial guess here is that you have two databases on the server - perhaps
    from restoring a backup as you mention, and that the clients are pointing to
    the database which has the old version. To see a list of databases on the
    server you can open the Data Tools and i.e. in the Delete dialog see all MOA
    databases and their versions.


    --
    Thanks
    Jesper
    http://blogs.msdn.com/jesperbirkolsen/
     
    Jesper [MS], Apr 26, 2007
    #2
    1. Advertisements

  3. How funny... even the MS reps are clueless.

    The workstations got the MOA service pack via automatic updates. The server
    did not. I figured this out on my own and have been able to reproduce it in
    the lab several times. Support had no clue either and said that the SP was
    NOT part of the automatic updates. They then backtracked and said well "maybe
    it was" but it had not yet filtered into the server updates que.

    Does the right hand have a clue what the left hand is doing?


     
    William Burnett, Apr 29, 2007
    #3
  4. thyde

    Data Waker Guest

    I have exactly the same error with full sql 2005 db on server, MOA *not* on
    server.

    This is what I'm going to try, hopefully later today, work permitting.

    Backup MOA/BCM *server* database and restore over the top of *local* MOA/BCM
    sql express DB.
    Point local copy of MOA to local DB and let it do the upgrade.
    Backup *local* update MOA/BCM database and restore over the top of *server*
    MOA/BCM database.
    Point MOA to server DB.

    Back and restore done using SQL 2005 management tools. BCM Data Utils
    should work for SQL express provided that it will restore to a different
    location.
     
    Data Waker, Apr 30, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.