New Company - Client Only - Existing remote SQL Server 2005


H

Harry Pfleger

Is it possible to install "Client Only" localy and than set up a new company on a existing remote SQL Server 2005? If yes, how?
This SQL Server uses the "Default Instance" name, so equal to No Instance Name, or?
Thankx, Cheers Harry
 
Ad

Advertisements

J

Jesper [MS]

Hi Harry

Yes, during install there is an "Advanced" button which allows you to select
instance or no instance at all.
You will then need to have an sbc-file that points to a database on a remote
server.
But you will need to create the company directly on the server as we don't
allow you to create a company remotely.

--
Thanks
Jesper
http://blogs.msdn.com/jesperbirkolsen/


Is it possible to install "Client Only" localy and than set up a new company
on a existing remote SQL Server 2005? If yes, how?
This SQL Server uses the "Default Instance" name, so equal to No Instance
Name, or?
Thankx, Cheers Harry
 
H

Harry Pfleger

Thankx Jesper
To create a company, do I need to install the client software or can I
"just" run some scripts?
Cheers Harry
 
H

Harry Pfleger

I figured that there is a <default.db> file available. Could I just use this
(restore)?

Since the SQL Server 2005 DB is installed on the default instance name (no
instance name), what would I need to put into the sbc file?
database=dbname
server=servername,1433
should the above work?

thankx, Harry
 
J

Jesper [MS]

No sorry. The default.db is a backup of a completely empty database with
only the schema.
In order to use it you would need to restore it and use the SDK to create a
company account with all settings. You would probably also need a chart of
accounts and many other enitites. So it would be more trouble than t's worth
to try that.
You could create the company on any machine you like and then backup and
restore it on the server using any tool.
And the sbc-file you mention below looks ok provided that is the port number
you use.
 
H

Harry Pfleger

Hi Jesper

database=dbname
server=servername,1433

This does not work.
It seems it needs a Instance name. I also tried:

server=servername\,1433

but this does also not work.
Any more suggestions.

Thankx, Harry
 
Ad

Advertisements

J

Jesper [MS]

Hi

I think that when using the default instance name you have to use:
database=[dbname]
server=[machine]\MSSQLSERVER,1433

The default instance name was changed in SQL 2005 to MSSQLSERVER.
Also note that connecting to it means that you have to set the port number
on the server, enable network protocols TCP/IP and open the firewall for
that port number.
 
H

Harry Pfleger

Thankx, Jesper

This is how it works on my computer:

database=[dbname]
server=[machine]\SQL Server,1433

Cheers Harry


Jesper said:
Hi

I think that when using the default instance name you have to use:
database=[dbname]
server=[machine]\MSSQLSERVER,1433

The default instance name was changed in SQL 2005 to MSSQLSERVER.
Also note that connecting to it means that you have to set the port number
on the server, enable network protocols TCP/IP and open the firewall for
that port number.

--
Thanks
Jesper
http://blogs.msdn.com/jesperbirkolsen/


Harry Pfleger said:
Hi Jesper

database=dbname
server=servername,1433

This does not work.
It seems it needs a Instance name. I also tried:

server=servername\,1433

but this does also not work.
Any more suggestions.

Thankx, Harry
 
Ad

Advertisements

R

Rob

This thread is exactly what I needed.


Just to follow up, I had to install officeAccounting on the SQL server to
install and build a new database.

Then I had to install it to the remote computer I actually want to run it
on. Using the sqlserverhostname\SQL Server,1433 I was able to connect.

Mucho thanks! There is absolutely 0 documentation on how to do this anywhere
else on the internet or documentation.

-Rob

Harry Pfleger said:
Thankx, Jesper

This is how it works on my computer:

database=[dbname]
server=[machine]\SQL Server,1433

Cheers Harry


Jesper said:
Hi

I think that when using the default instance name you have to use:
database=[dbname]
server=[machine]\MSSQLSERVER,1433

The default instance name was changed in SQL 2005 to MSSQLSERVER.
Also note that connecting to it means that you have to set the port number
on the server, enable network protocols TCP/IP and open the firewall for
that port number.

--
Thanks
Jesper
http://blogs.msdn.com/jesperbirkolsen/


Harry Pfleger said:
Hi Jesper

database=dbname
server=servername,1433

This does not work.
It seems it needs a Instance name. I also tried:

server=servername\,1433

but this does also not work.
Any more suggestions.

Thankx, Harry



No sorry. The default.db is a backup of a completely empty database with
only the schema.
In order to use it you would need to restore it and use the SDK to
create a company account with all settings. You would probably also need
a chart of accounts and many other enitites. So it would be more trouble
than t's worth to try that.
You could create the company on any machine you like and then backup and
restore it on the server using any tool.
And the sbc-file you mention below looks ok provided that is the port
number you use.

--
Thanks
Jesper
http://blogs.msdn.com/jesperbirkolsen/


I figured that there is a <default.db> file available. Could I just use
this (restore)?

Since the SQL Server 2005 DB is installed on the default instance name
(no instance name), what would I need to put into the sbc file?
database=dbname
server=servername,1433
should the above work?

thankx, Harry




Hi Harry

Yes, during install there is an "Advanced" button which allows you to
select instance or no instance at all.
You will then need to have an sbc-file that points to a database on a
remote server.
But you will need to create the company directly on the server as we
don't allow you to create a company remotely.

--
Thanks
Jesper
http://blogs.msdn.com/jesperbirkolsen/


Is it possible to install "Client Only" localy and than set up a new
company on a existing remote SQL Server 2005? If yes, how?
This SQL Server uses the "Default Instance" name, so equal to No
Instance Name, or?
Thankx, Cheers Harry
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top