Receipt Not posting to the Journal


S

Scott S

Just recently one of my stores has encountered an error after tendering a
sale. The POS station froze at printing receipts, when they get back in,
there is no receipt in the journal (Therefore the customer cannot get a
receipt). If it is a charge the transaction shows in the EDC batch or if I
run certain management reports it shows with a transaction number but I
cannot access the receipt.

Does anyone know what may be causing this problem, it is completely random
and has no rhyme or reason.


Thanks in Advance.

Scott
 
Ad

Advertisements

M

Marc

I have had this problem in the past and for me it was caused by a timeout
error. It happened very infrequently. There is no receipt and you will
probably find that the items from that transaction have not been removed
from inventory. The database transactions never complete.

The fix was to put the SQL protocols in the proper order. I do not remember
the proper order off the top of my head, but if you search this group you
will find at least one thread on the topic with instructions on ordering the
protocols.

Marc
 
P

Paul Houston / Eastern National

I've tried all the post and I have never completely eliminated it. The order
was
TCP/IP first and Named pipes second and add the alias of the server. If
someone ever finds the solution post it as I would like to eliminate this
accounting night mare. It may subtract from inventory and not post to the
journal
or not post ot the tender total. I have my operators using the Task manger to
close the Store POS and then restart the program. You may want to try to
reindex the DB frequently

Paul
 
M

Marc

Good point. I always rebooted the server to clear the problem, but
fortunately the protocol fix did work for us.

Marc


"Paul Houston / Eastern National"
 
M

Marc

There should be a server configuration manager utility that you can probably
find on the start menu under your server software, MSDE or SQL Server 2005.
You need to be a the PC that is running the server software.

Marc
 
Ad

Advertisements

J

Jeff @ Check Point Software

Follow these instructions on all RMS Server and Register machines (machines you install SQL on)

Start | Programs | SQL Server 2005 | Configuration Tools | double click on SQL Native Client Configuration on the left | double click Client Protocols | make sure that Named Pipes is enabled | right click on Named Pipes and select Order | change so the order is 2 if Shared Memory is #1, TCP/IP should be #3 | close


Start | Programs | SQL Server 2005 | Configuration Tools | SQL Surface Area Configuration | Surface Area Configuration for Services and Connections | select Remote Connections on the left | make sure that Local & Remote connections and Using both TCP/IP and Named Pipes is selected | close this screen Select Surface Area Configuration for Features | select Enable OPENROWSET and ... | close entirely


Turn off Auto_Close for SQL 2005/2008 Express http://tinyurl.com/or8kx . Not needed for full SQL Server installs.


For all machines with RMS installed;

Start | Programs | Microsoft Dynamics RMS or Retail Management System | Client Network Utility | move TCP/IP and Named Pipes to the right hand box, making sure that Named Pipes is on top | select the Alias tab | Add button | put either the computer name of the database server machine or the IP address of the server machine | close (The database server machine should always have a static IP address, that's another post)


Restart each machine




Just recently one of my stores has encountered an error after tendering a
sale. The POS station froze at printing receipts, when they get back in,
there is no receipt in the journal (Therefore the customer cannot get a
receipt). If it is a charge the transaction shows in the EDC batch or if I
run certain management reports it shows with a transaction number but I
cannot access the receipt.

Does anyone know what may be causing this problem, it is completely random
and has no rhyme or reason.


Thanks in Advance.

Scott
 
Ad

Advertisements

A

Alex

I have had two clients experiencing this issue in the past month. One
of them I was able to fix by using static IP addresses. The other one
still happens, but only around 9:30 AM every day.

I have pored over their servers for any processes that run around this
time but haven't found anything. Does anybody have any idea why this
may be happening? I have also tried the protocol trick at every
register.

Thanks,

Alex Nielsen
Retail Evolved
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Programmatically Posting a Receipt to the Journal 0
Journal Posting 1
Receipt not in journal 1
Journal Receipts 1
journal receipt 1
Receipts not journaling? 1
Will not post sales journal 0
Posting journal entry 1

Top