RMS 2.0 SO Manager abends after installation on Win 7 Professional

Discussion in 'Microsoft Point Of Sale' started by Gerd, Nov 2, 2009.

  1. Gerd

    Gerd Guest

    I just installed Win7 Pro on a new disk. I insalled RMS SO 2.0 with SP 2
    then 3, then I loaded SP for the SQL server 2005 Express.

    I can connect to the database with administrator but neither manager nor pos
    starts. I get the following popup (it's the same error for manager and pos)

    Store Operations Manager
    Class does not support Automation or does not support expected interface
    OK

    I am obviously missing something. I had copied the database from my Vista
    Business disk which was running fine there.

    Anybody can point me into the right direction?

    Thanks in advance
    Gerd
     
    Gerd, Nov 2, 2009
    #1
    1. Advertisements

  2. Gerd

    Gerd Guest

    So much for my maintenance $!
    I just got a call back from RMS support telling me that Win 7 and RMS has
    not been tested yet, thus, MS cannot provide any information nor solution to
    my problem.
     
    Gerd, Nov 2, 2009
    #2
    1. Advertisements

  3. Gerd,

    Are you using an Epson printer and installed the OPOS driver?

    If so, un-install the driver in Add/Remove and re-install it, making sure to select Common Control Object on the Select CO Type Window.

    Also check if there is a Win7 version of their drivers.




    I just installed Win7 Pro on a new disk. I insalled RMS SO 2.0 with SP 2
    then 3, then I loaded SP for the SQL server 2005 Express.

    I can connect to the database with administrator but neither manager nor pos
    starts. I get the following popup (it's the same error for manager and pos)

    Store Operations Manager
    Class does not support Automation or does not support expected interface
    OK

    I am obviously missing something. I had copied the database from my Vista
    Business disk which was running fine there.

    Anybody can point me into the right direction?

    Thanks in advance
    Gerd
     
    Jeff @ Check Point Software, Nov 2, 2009
    #3
  4. Gerd

    Gerd Guest

    I had found the KB about the Epson printer in Customersource. But I don't use an Epson printer, I use an IBM 4610 thermal printer.

    I had installed the latest version of that OPOS driver. The printers tests ok with the driver.

    I don't have any other devices (like pole display, cash drawer, pin pad) installed and configured, thus, the only OPOS device i have is the receipt printer.
    Gerd,

    Are you using an Epson printer and installed the OPOS driver?

    If so, un-install the driver in Add/Remove and re-install it, making sure to select Common Control Object on the Select CO Type Window.

    Also check if there is a Win7 version of their drivers.




    I just installed Win7 Pro on a new disk. I insalled RMS SO 2.0 with SP 2
    then 3, then I loaded SP for the SQL server 2005 Express.

    I can connect to the database with administrator but neither manager nor pos
    starts. I get the following popup (it's the same error for manager and pos)

    Store Operations Manager
    Class does not support Automation or does not support expected interface
    OK

    I am obviously missing something. I had copied the database from my Vista
    Business disk which was running fine there.

    Anybody can point me into the right direction?

    Thanks in advance
    Gerd
     
    Gerd, Nov 2, 2009
    #4
  5. Gerd

    ascimd Guest


    In the RMS Program Folder, Delete or rename the .manifest files. Eiter way, get rid of them in Win7.
     
    ascimd, Sep 16, 2013
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.