SBA 2009 SP2 - bug - cannot "upgrade" database


B

Bob

Just installed SBA 2009 SP2 from Windows Update - am running Windows 7, SQL
Server 2008.

When I launch SBA, it attempts to perform an upgrade of my database, and
after a few moments during the process it terminates with a database error (a
Named Pipes error - cannot connect to database, make sure remote connections
are enabled). It's a bogus error message - the database is accessible
otherwise...Named Pipes are enabled..and I am able to connect to it using SQL
Management Studio, for example.

I backed out SP2 and things are working fine again, so I must conclude that
SP2 has a pretty bad bug...can anyone else confirm this?
 
Q

Quilnux

Yeah, we're getting the same thing over here. We are running in a multi-user
environment. Not sure if that matters or not but we are trying to do the
upgrade from the server since that is where it is wanting us to do it from.
Named pipes is enabled and everything worked pre-SP2. We are planning out our
SP2 exit strategy and will be starting our uninstall phase this afternoon.
Thanks for confirming that uninstalling it works. We haven't been able to
test this thoery yet.

Once we finish our exit strategy we are going to look at the release notes
to see if there is anything in there regarding this problem.

Outside of that, it would seem that Microsoft needs to take a look at this.
 
Ad

Advertisements

M

MOAGUY

Hi,

Has anything in your configuration changed from last time you updated from
MOA 2009 to SP1 (Other than using Windows 7)?

Are you using a named instance of SQL2008? Did you update the existing
MSSMLBIZ instance using SQL2005 Express?

Out of the box, MOA does not recognize SQL2008 instances so I am guessing
you needed to do some sort of installation where you installed as client and
then pointed to the instance, is that correct?
 
Ad

Advertisements

S

smisakso

Hello,

I've been looking into this issue and I've concluded that when the upgrade
of your company data is started, the instance name that MOA looks at is
changed to something similar to "MSSMALLBUSINESS" as opposed to the default
"MSSMLBIZ".

Here's how to fix this:

1. Attempt the upgrade until you get the general network error.

2. Click "Start" "All Programs" "Microsoft Office" "Microsoft Office
Accounting 2009 Tools" "Data Tools".

3. Click on the "Settings" tab and change the "Instance Name" to equal
"MSSMLBIZ"

Note: If you're using a non-default instance of SQL, change it to that
instance name.

4. Re-attempt the upgrade and it will go through correctly.

Hope that helps.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top